A1465 EMC2924 EFI location.


Rendering Error in layout Widget/Social: Call to a member function exists() on null. Please enable debug mode for more information.
More
2 years 5 months ago - 2 years 5 months ago #6489 by Celhack
Hi, it's my first time R/w an EFI/bios. I have bus pirate and pomona clip, I want to know where efi is located on this model macbook air.

I have done many macs using bruteforce but this one not succeed.
Last edit: 2 years 5 months ago by Celhack. Reason: Correcting model number

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #6490 by Celhack
Replied by Celhack on topic A1465 EMC2924 EFI location.
I think this is the guy... Winbond ic right?
Attachments:
Last edit: 2 years 5 months ago by Celhack.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #6493 by Celhack
Replied by Celhack on topic A1465 EMC2924 EFI location.
I measured a pinout on test points. Can somebody help me with data sheet of this ic?

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #6496 by CygnusX1

Celhack wrote: I measured a pinout on test points. Can somebody help me with data sheet of this ic?


Here ya go!

cdn.sparkfun.com/datasheets/Dev/Teensy/w25q64fv.pdf

If I helped you buy me a latte!
The following user(s) said Thank You: dam1inc, Celhack

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #6497 by Celhack
Replied by Celhack on topic A1465 EMC2924 EFI location.
Thanks, I'm gonna try and let you know how it goes.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #6542 by Celhack
Replied by Celhack on topic A1465 EMC2924 EFI location.
Here is pinout on board...
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #6546 by Celhack
Replied by Celhack on topic A1465 EMC2924 EFI location.
No eeprom detected on flashrom. After solder all wires and try to read it, flashrom cant find the efi chip.

I run buspirate commands to check it and when I tried with their commands on terminal I get vreg is to low.

I measured all wires and check for short but everything is ok.

Can I try something different or do I need to desolder ic from board?

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #6547 by SomeGuy
Replied by SomeGuy on topic A1465 EMC2924 EFI location.
Goodluck bypassing it I had no luck with EFIDL or the other kind of unlockers by probing the vcc pin and or by using a probe tool on 3.3volt location on MB. Eventually I bricked the mac because I was trying everything under the sun and had the MAGSAFE plugged up while connecting the internal battery connector which I know was foolish. Now MBA Fan cuts on and off reloops over and over. I pulled board swapped with another board and now good to go lol

2015 MBA
MODEL A1465
EMC 2924

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #6550 by Celhack
Replied by Celhack on topic A1465 EMC2924 EFI location.

SomeGuy wrote: Goodluck bypassing it I had no luck with EFIDL or the other kind of unlockers by probing the vcc pin and or by using a probe tool on 3.3volt location on MB. Eventually I bricked the mac because I was trying everything under the sun and had the MAGSAFE plugged up while connecting the internal battery connector which I know was foolish. Now MBA Fan cuts on and off reloops over and over. I pulled board swapped with another board and now good to go lol

2015 MBA
MODEL A1465
EMC 2924


So, did you tried desoldering the efi and program out of the board? Also did you tried change the chip for a new one?
Last edit: 2 years 5 months ago by Celhack.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #6581 by Celhack
Replied by Celhack on topic A1465 EMC2924 EFI location.
Here is my update.....

EFDL didnt work with this MBA, it detect chip and finish the process but not done,EFI pass remain there.

So I used easy flash to connect with my bus pirate and it wok with this setting:
1- PC off.
2- Battery connected.
3- Magsafe Connected.

Please Log in or Create an account to join the conversation.

Who's Online

We have 189 guests and no members online

N00BZ

  • samaduck
  • donlan78
  • cyannyan
  • johnnybeast
  • gabry120

Cookies